题目链接:​​点我​​​ Problem Description
After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit.

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.)

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li.

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones’ value. while a necklace that is not palindrom has value zero.

Now the problem is: how to cut the given necklace so that the sum of the two necklaces’s value is greatest. Output this value.

Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows.

For each test case, the first line is 26 integers: v1, v2, …, v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind.

The second line of each test case is a string made up of charactor ‘a’ to ‘z’. representing the necklace. Different charactor representing different kinds of gemstones, and the value of ‘a’ is v1, the value of ‘b’ is v2, …, and so on. The length of the string is no more than 500000.

Output
Output a single Integer: the maximum value General Li can get from the necklace.

Sample Input
2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac

Sample Output
1
6

题目大意就是将字符串切成两份,有回文字符串的才能计算价值,
用Manacher 中p数组,判断两边是否有回文串
打表一个前缀和,便于查询,另外借助Manacher算法的p数组,将字符串分割,查询两边的字符串是否有回文串,然后递推出最大值

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cstdlib>
using namespace std;
const int MAXN=550000;
char str[MAXN<<1];
int p[MAXN<<1];
void Manacher(char s[],int len) //Manacher 模板
{
int l=0;
str[l++]='$';
str[l++]='#';
for(int i=0;i<len;i++)
{
str[l++]=s[i];
str[l++]='#';
}
str[l]=0;
int mx=0,id=0;
for(int i=0;i<l;i++)
{
p[i]=mx>i? min(p[2*id-i],mx-i):1;
while(str[i+p[i]] == str[i-p[i]]) p[i]++;
if(i+p[i] > mx)
{
mx = i+p[i];
id=i;
}
}
}
char s[MAXN];
int sum[MAXN<<1];
int v[30];
void get_sum()//前缀和
{
int len=strlen(str);
for(int i=1;i<len;i++)
{
sum[i] = sum[i-1];
if('a'<=str[i] && str[i]<='z')
sum[i] += v[str[i]-'a'+1];

}
}

int main()
{
int T;
cin>>T;
while(T--)
{
for(int i=1;i<=26;i++) scanf("%d",&v[i]);
scanf("%s",s);
int len=strlen(s);
Manacher(s,len);
get_sum();
len=strlen(str);//长度为原字符串的2倍再加上首尾两个。
int ans = 0;
for(int i=3;i<len-1;i=i+2)
{
int a1=0,a2=0;
if((1+i)/2+p[(2+(i-1))/2]-1 >= i-1) //检查前半部分能否构成回文字符串,应用p数组的性质
a1 = sum[i]-sum[1];
if((len+i-1)/2-p[(len+i-1)/2]+1 <= i+1)//同理检查后半部分能否构成回文字符串
a2 = sum[len-2]-sum[i];
if(ans<a1+a2)
ans = a1+a2;
}
cout<<ans<<endl;
}
}