-
VRRP
虚拟路由冗余协议,简称VRRP是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议。网络中部署VRRP负载分担时,多台设备同时承担业务,每个虚拟设备都包括一个Master设备和若干个Backup设备。如果为了接入备份设备需要同时部署冗余链路,则需要部署MSTP消除网络中的环路,保证流量的负载分担。 -
MSTP
以太网交换网络中为了进行链路备份,提高网络可靠性,通常会使用冗余链路。但是使用冗余链路会在交换网络上产生环路,引发广播风暴以及MAC地址表不稳定等故障现象,从而导致用户通信指令较差,甚至通信中断。为解决交换网络中的环路问题,提出了生成树协议STP。
STP用来解决网络中环路问题,运行该协议的设备通过彼此交互信息而发现网络中的环路,并对某些端口进行阻塞以消除环路。生成树协议中,MSTP兼容RSTP、STP,RSTP兼容STP。
STP:形成一颗无环路的树,解决广播风暴并实现冗余备份;收敛速度慢
RSTP:形成一颗无环路的树,解决广播风暴并实现冗余备份;收敛速度快
STP、RSTP无需区分用户或业务流量,所有VLAN共享一颗生成树;
MSTP:形成多颗无环路的树,解决广播风暴并实现冗余备份;收敛速度快;多颗生成树在VLAN间实现负载均衡,不同VLAN的流量按照不同的路径转发;
MSTP需要区分用户和业务流量,并实现负载分担。不同的VLAN通过不同的生成树转发流量,每颗生成树间相互独立; -
配置思路
1、VLAN划分
2、VRRP配置
3、MSTP配置
4、链路聚合配置
#VALN划分
VLAN batch 30 40
interface Vlanif30
ip address 192.168.30.253 255.255.255.0
quit
interface Vlanif40
ip address 192.168.40.253 255.255.255.0
quit
#VRRP配置
interface Vlanif30
vrrp vrid 30 virtual-ip 192.168.30.253//创建组号为30的VRRP备份组并为备份组指定虚拟IP地址192.168.30.253
vrrp vrid 30 priority 120//配置VRRP备份组30的优先级
quit
interface Vlanif40
vrrp vrid 40 virtual-ip 192.168.40.253
vrrp vrid 40 priority 100
quit
#MSTP配置
#SW-1/2/3/4的STP配置
stp region-configuration //STP域配置
region-name R34 //配置域名为R34
instance 1 vlan 30 //将VLAN30映射到实例1上
instance 2 vlan 40 //将VLAN40映射到实例2上
active region-configuration //激活MST域的配置
quit
SW-1:
stp instance 1 root primary //配置Switch1为MST1的根桥
syp instance 2 root secondary//配置Switch1为MST2的备份根桥
quit
SW-2:
stp instance 1 root secondary
stp instance 2 root primary
quit
主根桥与备份根桥之间的链路绑定Eth-Trunk1
SW-1:
interface Eth-Trunk1 //配置及接口Eth-Trunk1
prot link-type trunk //端口链路类型Trunk
port trunk allow-pass vlan 30 40 //端口trunk允许VLAN30 VLAN40通过
mode lacp-static //Eth-Trunk1使用lacp静态链路聚合协议
max active-linknumber 2 //最大活跃链路为2条
quit
SW-2:
interface Eth-Trunk1
port link-type trunk
port trunk allow-pass vlan 30 40
mode lacp-static
lacp preempt enable //启用lacp抢占模式
quit
#配置处于环网中的设备的二层转发功能
SW-1/2:
interface Eth-Trunk1
trunkport gigabitethernet 0/0/3 to 0/0/5 //将SW-1/2的GE0/0/3-GE0/0/5加入Eth-Trunk1中
SW-1:
interface GigabitEthernet 0/0/3
lacp priority 100 //设备lacp优先级
quit
interface GigabitEthernet 0/0/4
lacp priority 100
quit
SW-1/2:
interface GigabitEthernet 0/0/1
port link-type trunk
port trunk allow-pass vlan 30 40
quit
interface GigabitEthernet 0/0/2
port link-type trunk
port trunk allow-pass valan 30 40
quit
SW-3/4:
interface GigabitEthernet 0/0/1
port link-type trunk
port trunk allow-pass vlan 30 40
quit
interface GigabitEthernet 0/0/2
port link-type trunk
port trunk allow-pass vlan 30 40
quit
SW-3/4中的GE0/0/3接口配置(直连到PC端)
interface GigabitEthernet 0/0/3
port link-type access
port default vlan 30 //SW-3 GE 0/0/3接口对应VLAN30
port default vlan 40 //SW-4 GE 0/0/3接口对应VLAN40
quit
#验证配置
display vrrp/display vrrp brief
display stp brief