HDU 1423 Greatest Common Increasing Subsequence 最长公共递增序列
原创
©著作权归作者所有:来自51CTO博客作者我想有个名字的原创作品,请联系作者获取转载授权,否则将追究法律责任
Greatest Common Increasing Subsequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4647 Accepted Submission(s): 1484
Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
Output
output print L - the length of the greatest common increasing subsequence of both sequences.
Sample Input
1
5
1 4 2 5 -12
4
-12 1 2 4
Sample Output
2
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
#define N 505
int a[N],b[N],dp[N];
int main()
{
int i,j,k,n,m,max,t;
//freopen("text.txt","r",stdin);
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
scanf("%d",&m);
for(i=0;i<m;i++)
scanf("%d",&b[i]);
memset(dp,0,sizeof(dp));
max=-1;
for(i=0;i<n;i++)
for(j=0;j<m;j++)
{
if(a[i]==b[j])
{
dp[j]=1;
for(k=0;k<j;k++)
{
if(b[k]<b[j]&&dp[j]<dp[k]+1)
dp[j]=dp[k]+1;
}
}
if(dp[j]>max)
max=dp[j];
}
printf("%d\n",max);
if(t!=0)
printf("\n");
}
return 0;
}