Humble Numbers


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16506    Accepted Submission(s): 7160

Problem Description


A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.
Write a program to find and print the nth element in this sequence


Input


The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.


Output


For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.


Sample Input


1 2 3 4 11 12 13 21 22 23 100 1000 5842 0


Sample Output


The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.


/*
1058 求质因数2357的数
这题就是每个数的倍数 取最小的放入数组
注意输出的格式
*/
#include <iostream>
using namespace std;
int a[5843];
int b1=1,b2=1,b3=1,b4=1;
int Minum(int a,int b,int c ,int d)
{
int min;
min=a;
if(b<min) min=b;
if(c<min) min=c;
if(d<min) min=d;

//去掉重复的
if(min==a) b1++;
if(min==b) b2++;
if(min==c) b3++;
if(min==d) b4++;
return min;
}
int main()
{
int n,i,j;
a[1]=1;
for(i=2;i<5843;i++)
a[i]=Minum(2*a[b1],3*a[b2],5*a[b3],7*a[b4]);
while (cin>>n&&n)
{
if(n%10==1&&n%100!=11) printf("The %dst humble number is %d.\n",n,a[n]);
else if (n%10==2&&n%100!=12) printf("The %dnd humble number is %d.\n",n,a[n]);
else if (n%10==3&&n%100!=13) printf("The %drd humble number is %d.\n",n,a[n]);
else printf("The %dth humble number is %d.\n",n,a[n]);

}
return 0;
}