1、网络拓扑图
2、知识点
2.1 router-id选举规则
1)手动配置:如果通过命令router id
进行了配置,则按照配置结果设置Router ID。
2)Loopback接口:如果未通过命令router id
进行配置,设备会优先选择配置了IP地址的Loopback接口,并选择其中最大的地址作为Router ID。
3)物理接口:如果没有配置Loopback接口或Loopback接口没有配置IP地址,则从其他接口的IP地址中选择最大的一个作为Router ID,不考虑接口的UP/DOWN状态。
4)重新选举的条件:只有当被选为Router ID的接口地址被删除或修改时,才会触发重新选择Router ID的过程。其他情况,如接口状态改变,不会导致重新选择。
Router ID的作用和影响:
唯一标识:Router ID在OSPF区域中作为本路由器的唯一标识,必须全局唯一。如果Router ID不唯一,路由器之间无法建立邻居关系。
2.2 建立邻居规则
1)Router ID (RID) 必须不同:每个路由器必须有一个唯一的Router ID,以确保在网络中不会发生冲突。
2)Area ID 必须相同:建立邻居关系的路由器必须位于同一个Area中,这意味着它们的Area ID必须匹配。
3)认证方式必须相同:无论是使用明文认证、密文认证还是不认证,认证方式必须一致,以确保安全性和一致性。
4)Hello包间隔和死亡时间间隔必须相同:Hello包间隔和死亡时间间隔必须一致,以确保路由器能够正确地发现和维护邻居关系。hello间隔时间为10S,死亡时间为40S。
5)网络类型必须一致:网络类型(如广播、NBMA等)必须一致,以确保路由器能够正确地处理邻居发现和维持。
这些条件共同确保了OSPF协议在建立邻居关系时的稳定性和可靠性,从而有效地维护网络的连通性和路由信息的传递。
2.3 DR的选举规则
1)路由器的优先级:每个OSPF路由器都有一个优先级,数值范围为0-255,默认值为1。优先级越高,成为DR的机会越大。如果两个路由器的优先级相同,则将比较路由器ID。
2) 路由器ID:每个OSPF路由器都有一个唯一的路由器ID,通常为IPv4地址。路由器ID由以下三个因素中的一个确定:手动配置、最高回环接口的IPv4地址、最高活动物理接口的IPv4地址。路由器ID较高的路由器将成为DR,较低的将成为BDR。
3)优先级为0的路由器:如果路由器的优先级设置为0,则该路由器不能成为DR或BDR。这对于设计单一连接的无线网络或需控制洪泛范围的场景很有用。
4) BDR的作用:BDR是备份DR,用于在DR发生故障时接管DR的功能。BDR将保留与DR相同的基本路由器功能,并与其他非DR和BDR路由器建立邻居关系。
3、详细配置
R1:
[r1]display current-configuration
[V200R003C00]
#
sysname r1
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 10.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 1.1.1.1 255.255.255.255
#
ospf 100 router-id 1.1.1.1
area 0.0.0.0
network 10.1.1.0 0.0.0.255
#
user-interface con 0
authentication-mode password
idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
[r1]
R2:
[r2]display current-configuration
[V200R003C00]
#
sysname r2
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 10.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
#
ospf 100 router-id 2.2.2.2
area 0.0.0.0
network 10.1.1.0 0.0.0.255
#
user-interface con 0
authentication-mode password
idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
[r2]
R3:
[r3]display current-configuration
[V200R003C00]
#
sysname r3
#
snmp-agent local-engineid 800007DB03000000000000
snmp-agent
#
clock timezone China-Standard-Time minus 08:00:00
#
portal local-server load portalpage.zip
#
drop illegal-mac alarm
#
set cpu-usage threshold 80 restore 75
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0`8bmE3Uw}%$%$
local-user admin service-type http
#
firewall zone Local
priority 15
#
interface GigabitEthernet0/0/0
ip address 10.1.1.3 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0
ip address 3.3.3.3 255.255.255.0
#
ospf 100 router-id 3.3.3.3
area 0.0.0.0
network 10.1.1.0 0.0.0.255
#
user-interface con 0
authentication-mode password
idle-timeout 0 0
user-interface vty 0 4
user-interface vty 16 20
#
wlan ac
#
return
[r3]