还是畅通工程

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60137    Accepted Submission(s): 27329

Problem Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5

Hint

Hint Huge input, scanf is recommended.

Source

浙大计算机研究生复试上机考试-2006年

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1102 1875 1879 1301 1162 

思路

裸的求最小生成树,模板题。

题目大意:给定一个无向图的·n个点,N(N-1)/2条边,求求连接所有点的最短路径。

方法:裸的求最小生成树,模板题,直接Kruskal即可。

AC Code

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm> 
using namespace std;
const int nmax=110;
const int mmax=1e4+10; 
int n,m;//点数、边数 
struct Edge{
	int u,v,val;//起点、终点、边权 
}edge[mmax];
 
bool cmp(Edge a,Edge b){
	return a.val<b.val; //按照边权从小到大排序,求最小生成树 
} 
 
int father[nmax];
int findFather(int u){
	if(u==father[u]) return u;
	else{
		int f=findFather(father[u]);
		father[u]=f;
		return f;
	}
}
 
void init(int n){
	for(int i=1;i<=n;i++){
		father[i]=i;
	}
} 
void Kruskal(){//返回最小生成树的边权和
    init(n); 
    //sort(edge,edge+m,cmp); 
	int cnt=0;//有效合并次数 
	int ans=0;//最小边权和 
	for(int i=0;i<m;i++){//遍历m条边
		int fu=findFather(edge[i].u);
		int fv=findFather(edge[i].v);
		if(fu!=fv){
			father[fu]=fv;
			ans+=edge[i].val;
			cnt++;
		}
		if(cnt==n-1)//合并了N-1条边,已经找到了最小生成树
			break; 
	} 
	if(cnt==n-1)//找到最小生成树
		printf("%d\n",ans);
	else		//图不连通 
		printf("?\n");
}
 
int main(int argc, char** argv) {
	while(scanf("%d",&n)!=EOF){
		if(n==0){
			break;
		}
		memset(father,0,sizeof(father));
		memset(edge,0,sizeof(edge));
		init(n);
		m=n*(n-1)/2;
		for(int i=0;i<m;i++){
			scanf("%d %d %d",&edge[i].u,&edge[i].v,&edge[i].val);
		}
		sort(edge,edge+m,cmp); 
		Kruskal();
	}
	return 0;
}