</pre>题干:<p></p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)">给定一个k位整数N = d<sub style="line-height:0">k-1</sub>*10<sup style="line-height:0">k-1</sup> + ... + d<sub style="line-height:0">1</sub>*10<sup style="line-height:0">1</sup> + d<sub style="line-height:0">0</sub> (0<=d<sub style="line-height:0">i</sub><=9, i=0,...,k-1, d<sub style="line-height:0">k-1</sub>>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定N = 100311,则有2个0,3个1,和1个3。</p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)"><strong>输入格式:</strong></p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)">每个输入包含1个测试用例,即一个不超过1000位的正整数N。</p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)"><strong>输出格式:</strong></p><p style="margin-top:0px; margin-bottom:1.5em; padding-top:0px; padding-bottom:0px; border:0px; line-height:18px; font-family:'Droid Sans',Verdana,'Microsoft YaHei',Tahoma,sans-serif; vertical-align:baseline; color:rgb(51,51,51); background-color:rgb(250,250,250)">对N中每一种不同的个位数字,以D:M的格式在一行中输出该位数字D及其在N中出现的次数M。要求按D的升序输出。</p><span >输入样例:</span><pre style="margin-top:1.5em; margin-bottom:1.5em; padding:0px; border:0px; line-height:18px; font-family:'Droid Sans Mono',Consolas,'Courier New',monospace; vertical-align:baseline; overflow:auto; color:rgb(51,51,51); background-color:rgb(250,250,250)">100311
输出样例:
0:2 1:3 3:1
水题,详见代码:
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char s[1005];
int a[10];
int main(){
int i,l;
while(cin>>s){
l = strlen(s);
memset(a,0,sizeof(a));
for(i = 0;i < l;i++){
a[s[i] - '0']++;
}
for(i = 0;i < 10;i++){
if(a[i]!=0)
printf("%d:%d\n",i,a[i]);
}
}
return 0;
}