R1:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.1.1 255.255.255.0
!
interface Tunnel100
 no ip address
 tunnel source 1.1.123.1
 tunnel destination 1.1.123.30
!
interface FastEthernet0/0
 ip address 1.1.123.1 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 402 interface Serial1/2 204
 frame-relay route 403 interface Tunnel100 234
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 204 interface Serial1/0 402
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 110
 router-id 1.1.1.1
 log-adjacency-changes
 area 2 nssa
 redistribute connected
 network 1.1.123.1 0.0.0.0 area 2
 network 10.10.1.1 0.0.0.0 area 2
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 935
 privilege level 15
 no login
!
!        
end

 

 

 

 

 

 

 

 

 

 

 


R2:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.2.2 255.255.255.0
!
interface Loopback2
 ip address 22.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 1.1.123.2 255.255.255.224
 ip ospf priority 0
 duplex auto
 speed auto
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 ip address 1.1.234.2 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint non-broadcast
 serial restart-delay 0
 clock rate 64000
 frame-relay map ip 1.1.234.3 204
 frame-relay map ip 1.1.234.4 204
 no frame-relay inverse-arp
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 110
 router-id 2.2.2.2
 log-adjacency-changes
 area 0 authentication message-digest
 area 1 virtual-link 4.4.4.4 authentication message-digest
 area 1 virtual-link 4.4.4.4 message-digest-key 1 md5 cisco
 area 2 nssa no-redistribution
 network 1.1.123.2 0.0.0.0 area 2
 network 1.1.234.2 0.0.0.0 area 1
 network 10.10.2.2 0.0.0.0 area 1
 network 22.1.1.1 0.0.0.0 area 20
 neighbor 1.1.234.4
!        
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 935
 privilege level 15
 no login
!
!
end

 

 

 

 

 

 

 

 

 

 

 


R3:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.3.3 255.255.255.0
!
interface Loopback3
 ip address 30.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 1.1.123.3 255.255.255.224
 ip ospf priority 0
 duplex auto
 speed auto
!        
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 ip address 1.1.234.3 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint non-broadcast
 serial restart-delay 0
 clock rate 64000
 frame-relay map ip 1.1.234.4 304
 frame-relay map ip 1.1.234.2 304
 no frame-relay inverse-arp
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 110
 router-id 3.3.3.3
 log-adjacency-changes
 area 0 authentication message-digest
 area 1 virtual-link 4.4.4.4 authentication message-digest
 area 1 virtual-link 4.4.4.4 message-digest-key 1 md5 cisco
 area 2 nssa no-redistribution default-information-originate metric 20
 area 30 range 10.10.3.0 255.255.255.0
 network 1.1.123.3 0.0.0.0 area 2
 network 1.1.234.3 0.0.0.0 area 1
 network 10.10.3.3 0.0.0.0 area 30
 network 30.1.1.1 0.0.0.0 area 30
 neighbor 1.1.234.4
 distance 255 5.5.5.5 0.0.0.0
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 935
 privilege level 15
 no login
!
!
end

 

 

 

 

 

 

 

 

 

 

 

 


R4:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.4.4 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 1.1.234.4 255.255.255.248
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf network point-to-multipoint non-broadcast
 serial restart-delay 0
 clock rate 64000
 frame-relay map ip 1.1.234.2 402
 frame-relay map ip 1.1.234.3 403
 no frame-relay inverse-arp
!
interface Serial1/1
 ip address 1.1.45.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/2
 no ip address
 no ip split-horizon
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 110
 router-id 4.4.4.4
 log-adjacency-changes
 area 0 authentication message-digest
 area 1 virtual-link 2.2.2.2 authentication message-digest
 area 1 virtual-link 2.2.2.2 message-digest-key 1 md5 cisco
 area 1 virtual-link 3.3.3.3 authentication message-digest
 area 1 virtual-link 3.3.3.3 message-digest-key 1 md5 cisco
 network 1.1.45.4 0.0.0.0 area 0
 network 1.1.234.4 0.0.0.0 area 1
 network 10.10.4.4 0.0.0.0 area 0
 neighbor 1.1.234.2
 neighbor 1.1.234.3 cost 99
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 935
 privilege level 15
 no login
!
!
end

 

 

 

 

 

 

 

 

 

 


R5:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
frame-relay switching
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.10.5.5 255.255.255.0
!
interface Tunnel100
 no ip address
 tunnel source 1.1.123.30
 tunnel destination 1.1.123.1
!
interface FastEthernet0/0
 ip address 1.1.123.30 255.255.255.224
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 ip address 1.1.45.5 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
 clock rate 64000
!
interface Serial1/2
 no ip address
 encapsulation frame-relay
 serial restart-delay 0
 clock rate 64000
 frame-relay intf-type dce
 frame-relay route 304 interface Tunnel100 234
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 110
 router-id 5.5.5.5
 log-adjacency-changes
 area 0 authentication message-digest
 network 1.1.45.5 0.0.0.0 area 0
 network 10.10.5.5 0.0.0.0 area 0
!
!
!
ip http server
no ip http secure-server
!
!        
!
!
!
!
control-plane
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 935
 privilege level 15
 no login
!
!
end