eigrp实验(一)--config basic eigrp_eigrp
每台路由器上的配置:
 
r1#show runn
Building configuration...
Current configuration : 1332 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
ip subnet-zero
ip cef
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback2
 ip address 10.1.3.1 255.255.255.0
!
interface Loopback3
 ip address 10.1.4.1 255.255.255.0
!
interface Serial1/1
 ip address 172.16.1.1 255.255.255.252
 serial restart-delay 0
!
router eigrp 10
 network 10.0.0.0
 network 172.16.0.0
 no auto-summary
!
ip classless
no ip http server
!
!
end

r2#show runn
Building configuration...
Current configuration : 1109 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
ip subnet-zero
ip cef
!
interface Loopback0
 ip address 131.131.1.1 255.255.0.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 ip address 172.16.1.2 255.255.255.252
 serial restart-delay 0
!
interface Serial1/1
 ip address 172.16.1.5 255.255.255.252
 serial restart-delay 0
!
router eigrp 10
 network 131.131.0.0
 network 172.16.0.0
 auto-summary
!
ip classless
no ip http server
!
!
dial-peer cor custom
!
end
 
r3#show runn
Building configuration...
Current configuration : 1397 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
!
ip subnet-zero
ip cef
 
 
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.0
!
interface Loopback1
 ip address 192.168.1.1 255.255.255.0
!
interface Loopback2
 ip address 192.168.2.1 255.255.255.0
!
interface Loopback3
 ip address 192.168.3.1 255.255.255.0
!
interface Serial1/0
 ip address 172.16.1.6 255.255.255.252
 ip summary-address eigrp 10 192.168.0.0 255.255.252.0 5
 serial restart-delay 0
!
router eigrp 10
 network 172.16.0.0
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 auto-summary
!
ip classless
no ip http server
!        
 
 
邻居表:
r2#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H   Address                 Interface   Hold Uptime   SRTT   RTO     Q       Seq Type
                                                              (sec)               (ms)             Cnt       Num
1   172.16.1.1              Se1/0         10 00:15:56           40        240       0        2  
0   172.16.1.6              Se1/1         13 00:17:29           831      4 986    0        4  
 
 
H 栏 — 按照发现顺序列出邻居。
.Address — 该邻居的 IP 地址。
.Interface — 收到此 Hello 数据包的本地接口。
.Hold — 当前的保留时间。每次收到 Hello 数据包时,此值即被重置为最大保留时间,然后倒计时,到零为止。如果到达了零,则认为该邻居进入 "down"。
.Uptime(运行时间)— 从该邻居被添加到邻居表以来的时间。
.SRTT(平均回程计时器)和 RTO(重传间隔)— 由 RTP 用于管理可靠 EIGRP 数据包。
.Queue Count(队列数)— 应该始终为零。如果大于零,则说明有 EIGRP 数据包等待发送。
.Sequence Number(序列号)— 用于跟踪更新、查询和应答数据包。
 
拓扑表:
r2#show ip eigrp topology
IP-EIGRP Topology Table for AS(10)/ID(131.131.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
P 131.131.0.0/16, 1 successors, FD is 128256
         via Connected, Loopback0
P 10.0.0.0/8, 1 successors, FD is 2297856
         via 172.16.1.1 (2297856/128256), Serial1/0
P 192.168.0.0/24, 1 successors, FD is 2297856
         via 172.16.1.6 (2297856/128256), Serial1/1
P 192.168.1.0/24, 1 successors, FD is 2297856
         via 172.16.1.6 (2297856/128256), Serial1/1
P 192.168.2.0/24, 1 successors, FD is 2297856
         via 172.16.1.6 (2297856/128256), Serial1/1
P 192.168.3.0/24, 1 successors, FD is 2297856
         via 172.16.1.6 (2297856/128256), Serial1/1
P 172.16.1.4/30, 1 successors, FD is 2169856
         via Connected, Serial1/1
P 172.16.0.0/16, 1 successors, FD is 2169856
         via Summary (2169856/0), Null0
P 172.16.1.0/30, 1 successors, FD is 2169856
         via Connected, Serial1/0
路由条目为p标志是为正常的 为A是不正常的。拓扑表中主要显示的是路由的状态
后继路由器数和FD(可行距离),注意,只显示后继路由和可行后继路由(提供备用路由的路由器),加上alll-links ,可显示其他的路由
r2#show ip eigrp topology all-links
IP-EIGRP Topology Table for AS(10)/ID(131.131.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
P 131.131.0.0/16, 1 successors, FD is 128256, serno 7
         via Connected, Loopback0
P 10.0.0.0/8, 1 successors, FD is 2297856, serno 9
         via 172.16.1.1 (2297856/128256), Serial1/0
P 192.168.0.0/24, 1 successors, FD is 2297856, serno 3
         via 172.16.1.6 (2297856/128256), Serial1/1
P 192.168.1.0/24, 1 successors, FD is 2297856, serno 4
         via 172.16.1.6 (2297856/128256), Serial1/1
P 192.168.2.0/24, 1 successors, FD is 2297856, serno 5
         via 172.16.1.6 (2297856/128256), Serial1/1
P 192.168.3.0/24, 1 successors, FD is 2297856, serno 6
         via 172.16.1.6 (2297856/128256), Serial1/1
P 172.16.1.4/30, 1 successors, FD is 2169856, serno 2
         via Connected, Serial1/1
P 172.16.0.0/16, 1 successors, FD is 2169856, serno 8
         via Summary (2169856/0), Null0
P 172.16.1.0/30, 1 successors, FD is 2169856, serno 1
         via Connected, Serial1/0
 
 
路由表:
r2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.1.4/30 is directly connected, Serial1/1
D       172.16.0.0/16 is a summary, 00:45:41, Null0
C       172.16.1.0/30 is directly connected, Serial1/0
D    10.0.0.0/8 [90/2297856] via 172.16.1.1, 00:44:26, Serial1/0
C    131.131.0.0/16 is directly connected, Loopback0
D    192.168.0.0/24 [90/2297856] via 172.16.1.6, 00:45:59, Serial1/1
D    192.168.1.0/24 [90/2297856] via 172.16.1.6, 00:45:59, Serial1/1
D    192.168.2.0/24 [90/2297856] via 172.16.1.6, 00:45:59, Serial1/1
D    192.168.3.0/24 [90/2297856] via 172.16.1.6, 00:45:59, Serial1/1
 
 
172.16.0.0/16 is a summary, 00:45:41, Null0     前面的部分是默认情况下采取的自动汇总,null0作用 可避免路由器将数据流转发到其他路由器是寻找更准确,匹配程度更高的路由,进而避免数据流在网络内循环,造成带宽的浪费和路由器cpu处理负荷的增加。
90/2297856     90EIGRP内部的管理距离      2297856   是EIGRP计算的度量(FD)
 
D    10.0.0.0/8 [90/2297856] via 172.16.1.1, 01:02:18, Serial1/0
R1路由器自动汇总的路由
 
当关闭R1 上的自动汇总时,R2路由表上出现的变化为:
    10.0.0.0/24 is subnetted, 4 subnets
D       10.1.3.0 [90/2297856] via 172.16.1.1, 00:00:11, Serial1/0
D       10.1.2.0 [90/2297856] via 172.16.1.1, 00:00:11, Serial1/0
D       10.1.1.0 [90/2297856] via 172.16.1.1, 00:00:11, Serial1/0
D       10.1.4.0 [90/2297856] via 172.16.1.1, 00:00:11, Serial
 
EIGRP也可以进行手工地址总结。手工地址总结,可以有效的减少路由表的大小。比如在R2上的路由中关于R3192.168.*.*的网络显示为四条具体路由,可以在R3上进行如下配置,减少路由通告条目。
 
r3(config)#inter s1/0
r3(config-if)#ip summary-address eigrp 10 192.168.0.0 255.255.252.0
 
r2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.16.1.4/30 is directly connected, Serial1/1
D       172.16.0.0/16 is a summary, 01:15:40, Null0
C       172.16.1.0/30 is directly connected, Serial1/0
     10.0.0.0/24 is subnetted, 4 subnets
D       10.1.3.0 [90/2297856] via 172.16.1.1, 00:08:37, Serial1/0
D       10.1.2.0 [90/2297856] via 172.16.1.1, 00:08:37, Serial1/0
D       10.1.1.0 [90/2297856] via 172.16.1.1, 00:08:37, Serial1/0
D       10.1.4.0 [90/2297856] via 172.16.1.1, 00:08:37, Serial1/0
C    131.131.0.0/16 is directly connected, Loopback0
D    192.168.0.0/22 [90/2297856] via 172.16.1.6, 00:00:08, Serial1/1
 
network 中的网络可以是有类的网络号 也可以是采用通配符掩码的方式,后者可以有选择的将指定的接口参与到eigrp的进程中