Router#show run
Building configuration...

Current configuration : 1693 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
aaa authorization network google local

!
aaa session-id common
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username cisco privilege 15 password 0 cisco
!
!
controller E1 0/0/0
!
!
!
crypto isakmp policy 10
encr 3des
authentication pre-share
group 2

!
crypto isakmp client configuration group google (设置vpn登录帐号)
key
www.google.com (设置vpn登录密码)
dns 202.96.134.133
pool ×××DHCP
!
!
crypto ipsec transform-set R1 esp-3des esp-sha-hmac
!
crypto dynamic-map dyvpn 10
set transform-set R1
reverse-route
!
!
crypto map dyvpn isakmp authorization list google
crypto map dyvpn client configuration address respond
crypto map dyvpn 1 ipsec-isakmp dynamic dyvpn
!
!
!
interface FastEthernet0/0
ip address 202.108.108.247 255.255.255.240
duplex auto
speed auto
crypto map dyvpn
!
interface FastEthernet0/1
description LAN$ES_LAN$
ip address 192.16.106.125 255.255.255.128
duplex auto
speed auto
!
ip local pool ×××DHCP 192.16.106.122 192.16.106.123 (×××登录后自动分配的IP地址)
ip local pool ×××DHCP 192.16.106.29
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 202.108.108.254
ip route 192.0.0.0 255.0.0.0 192.16.106.1
!
!
ip http server
ip http authentication local
no ip http secure-server
!
disable-eadi
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
!
scheduler allocate 20000 1000
end